webpack4 系列教程(二): 编译 ES6 2019-07-11

今天介绍webpack怎么编译ES6的各种函数和语法。敲黑板:这是webpack4版本哦, 有一些不同于webpack3的地方。

>>> 本节课源码

>>> 所有课程源码

1. 了解babel

说起编译es6,就必须提一下babel和相关的技术生态:

    babel-loader: 负责 es6 语法转化babel-preset-env: 包含 es6、7 等版本的语法转化规则babel-polyfill: es6 内置方法和函数转化垫片babel-plugin-transform-runtime: 避免 polyfill 污染全局变量

需要注意的是, babel-loaderbabel-polyfill。前者负责语法转化,比如:箭头函数;后者负责内置方法和函数,比如:new Set()

2. 安装相关库

这次,我们的package.json文件配置如下:

{ "devDependencies": { "babel-core": "^6.26.3", "babel-loader": "^7.1.5", "babel-plugin-transform-runtime": "^6.23.0", "babel-preset-env": "^1.7.0", "webpack": "^4.15.1" }, "dependencies": { "babel-polyfill": "^6.26.0", "babel-runtime": "^6.26.0" }}

>>> package.json 配置地址

3. webpack中使用babel

babel的相关配置,推荐单独写在.babelrc文件中。下面,我给出这次的相关配置:

{ "presets": [ [ "env", { "targets": { "browsers": ["last 2 versions"] } } ] ], "plugins": ["transform-runtime"]}

webpack配置文件中,关于babel的调用需要写在module模块中。对于相关的匹配规则,除了匹配js结尾的文件,还应该去除node_module/文件夹下的第三库的文件(发布前已经被处理好了)。

module.exports = { entry: { app: "./app.js" }, output: { filename: "bundle.js" }, module: { rules: [ { test: /.js$/, exclude: /(node_modules)/, use: { loader: "babel-loader" } } ] }};

>>> .babelrc 地址

>>> 配置文件地址

4. 最后:babel-polyfill

我们发现整个过程中并没有使用babel-polyfill它需要在我们项目的入口文件中被引入,或者在webpack.config.js中配置。这里我们采用第一种方法编写app.js:

import "babel-polyfill";let func = () => {};const NUM = 45;let arr = [1, 2, 4];let arrB = arr.map(item => item * 2);console.log(arrB.includes(8));console.log("new Set(arrB) is ", new Set(arrB));

命令行中进行打包,然后编写html文件引用打包后的文件即可在不支持es6规范的老浏览器中看到效果了。

5. 相关资料

polyfill 引入:https://www.babeljs.cn/docs/usage/polyfill/babel-preset-env 配置:https://www.babeljs.cn/docs/plugins/preset-env/

欢迎技术交流,引用请注明出处。个人网站:Yuan Xin原文链接:webpack4 系列教程(二): 编译 ES6

Copyright © 2019 laba360官网 All Rights Reserved
陈振平
地址:北京市首创新悦都
全国统一热线:15387288658